Skip to main content

Posts

Showing posts from January, 2009

Flash player not working in Firefox in Ubuntu (Hardy)

I installed flashblock plugin or upgraded to the Ubuntu customized version of the Firefox I do no know what caused that but I stopped having any flash video in Firefox 3.0 even after repeated installs using the deb and tar.gz packages downloaded from the Adobe website. I tried installing Opera and flash worked fine in that.

That is when I noticed when running from terminal Firefox is displaying a lot of missing shared object) files, like this :

LoadPlugin: failed to initialize shared library /home/aaaaaa/.mozilla/plugins/libflashplayer.so [libplds4.so: cannot open shared object file: No such file or directory]
LoadPlugin: failed to initialize shared library /usr/lib/adobe-flashplugin/libflashplayer.so [libplds4.so: cannot open shared object file: No such file or directory]

The idea is that in some way all the soft links to the *.so.1d or *.so.0d files are deleted. So I had to recreate them. The following link helped a lot to that end.

https://lists.ubuntu.com/archives/ubuntu-mozillateam-bu…

How to access anna's share from linux and see movies

Method I :
Make a folder named /home/share

Issue a command like

mount -t smbfs //192.168.x.x/movies/home/share -o username=guest,password=

put anna's IP instead of 192.168.x.x


Method II (for non-terminal guys):

Open Konqueror (KDE)or Nautilus(Gnome) or Dolphin (KDE 4.1)
In the address bar type,

smb://guest@192.168.x.x/

In the prompt for password etc. just cancel.

Enjoy !!!

________________________

To see the movies in Linux, install mplayer or vlc player.
mplayer is preferable to manipulate rowdy subtitles while vlc is better for sound etc.
But there is a way to get loud sound in mplayer. That is a trade secet ;)

Cifs "mount error 13 = Permission denied"

This was a huge problem in samba especially in Ubuntu. It seems that the new kernal is to blame.
Whenever I issued a command like

mount -t smbfs //192.168.87.85/LOTR /share/ -o username=guest,password=

I got the error

mount error 13 = Permission denied
Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)

A bug report is found
here( https://bugzilla.redhat.com/show_bug.cgi?id=119766).

And a possible solution is given here.( http://vijayk.blogspot.com/2008/09/cifs-mount-error-13-permission-denied.html)

However it didn't help when I gave this command,

mount -t smbfs //192.168.87.85/LOTR /share/ -o username=guest,password=

After a lot of experimenting I realised that it fails sometimes if there is no password specified. So I added a password to the Windows share and gave the following command.

mount -t smbfs //192.168.87.85/LOTR /share/ -o username=guest,password=gjf67g,domain=MSHOME

It worked !!!

For many other win shares I didn't specify password and the first command worked fine. I…